This project is read-only.

FatalExecutionEngineError was detected

Oct 9, 2012 at 4:39 PM

Hi all,

I've been using the Javascript .NET project (v0.6) for a while now and perhaps once out of every 5 runs it would fail with the following error:

The runtime has encountered a fatal error. The address of the error was at 0xf0b41380, on thread 0xe34. The error code is 0xc0000005. This error may be a bug in the CLR or in the unsafe or non-verifiable portions of user code. Common sources of this bug include user marshaling errors for COM-interop or PInvoke, which may corrupt the stack.

Now, thinking it could be an older library issue I tried the v0.7 binaries and it's happening even more frequently. Any suggestions on what to try with this guy? Thanks for the help.

Oct 9, 2012 at 11:03 PM

If you can reduce it to a very simple example then that will help.

Oct 17, 2012 at 4:09 PM

syoutsey, try putting the other files that come with Noesis.Javascript.dll into the bin\Debug\ and bin\Release\ folders of your project.

The list of files are:

  • Microsoft.VC90.CRT.manifest
  • msvcm90.dll
  • msvcp90.dll
  • msvcr90.dll
Oct 18, 2012 at 5:43 PM

I'll give that a shot, thanks.

Nov 6, 2012 at 6:48 PM

I tried the suggestion but I'm still getting this error. The exact exception is:

+ $exception {Cannot evaluate expression because a native frame is on top of the call stack.} System.Exception {System.ExecutionEngineException}
Any ideas are greatly appreciated.

Nov 8, 2012 at 12:09 AM

Hi syoutsey,

I'll be glad to take a look at your project or you can post some code or a small project that reproduces the error.

Nov 8, 2012 at 4:29 PM

Cool, thanks for the offer. Since it's not immediately reproducible I'll try to put something together that's a good showcase of the bug. Thanks again.

Nov 9, 2012 at 2:30 PM

Great, also I wanted to mention that maybe this unreleased patch has something to do with it (read the commit message) -

Nov 14, 2012 at 8:35 PM

Hi waynebloss, I just tried building from source and using that DLL but still no luck :-/ It's a bit tricky to reproduce as it only happens occasionally, is there any way I can get you some code for a bit of analysis? Thanks in advance!

Nov 16, 2012 at 1:41 AM


Create a new issue here:

Paste your original question in there.

Then, attach a zip file containing your project which reproduces the problem.

Thank You.

Nov 20, 2012 at 4:26 PM

waynebloss, I'll try to put something together which reproduces it. I've started a new project and reimported the files and haven't seen the error again. The only difference between the two projects was that the first error-prone one was registered for COM interop and was being signed. Perhaps these configuration settings had something to do with it.

Regardless, thanks for the help.